PiPo M9 drop dead?


Hey!
I had a PiPo M9 (WiFi) now for about 2-3 weeks and everything worked perfectly.
No problems with rooting and installing ROMS ( i fixed that 2-3 days after i bought it)




I was playing some angry birds yesterday, and all of sudden i had VERY low battery, i put it on charge even if i recently took it from it.
Then i noticed that the DC-connection in my tablet is "loose" , i needed to have the cable in a specific position for make it charge.
Battery was fully charged but it said i had about 16 minutes left, and in 1 minute it dropped to 43% and only had 2 minutes of the battery left...
I tried to calibrate the battery after it was fully charged (i let it charge for almost 10 hours) but there was no difference...


Anyways... i played some games later on and forgot about the position of the cable so the tablet died...It had a bootloop about 6 times and i was trying to put the cable correct for make it charge but i failed and the tablet died.
Now it doesnt react at all, and unfortunally i don't know what the EXACTLY position is for the cable so i have been trying around but without success...


When i am connecting the USB to the computer it doens't react either, and i tried to push in RESET while holding the other buttoms as well, without success...
I Don't know what to do , and i don't know what is wrong?
I opened up my tablet carefully to see if i could see the problem but it is hard to do anything without knowledge about it....


I know that it has something to do with the DC-connection but i can also imagine that it has something to do with the batteries..
If i need to change the batteries , what should i buy? And how should i do? I need a guide, walkthrough ,... i have been googling around , also on youtube, without any luck...




Anyone out there who can help me?


I am kinda desperate.. :/

You need to be logged in to the site to leave comments.

Login  •  Register


Return to “Rockchip RK3188”



Who is online

Users browsing this forum: No registered users and 2 guests